Después de actualizar Ubuntu a la versión 9.10. tuve algunos problemas con Eclipse.

Lo primero es que algunos botones de Eclipse dejaron de responder al pulsarlos con el ratón. De este problema ya estaba prevenido por DiarioLinux y como indican en este blog añado a mi eclipse.sh la siguiente línea:

export GDK_NATIVE_WINDOWS=1

El siguiente problema fue que Subclipse dejó de funcionar mostrando el siguiente error:

Este problema se produce porque la actualización de Ubuntu deja Subversion en la versión 1.6.5. y la versión de Subclipse que tenía instalada, la 1.4., no es compatible.

Me dispuse a actualizar Subclipse a la versión 1.6. pero Eclipse no hacía otra cosa que cerrarse de forma inesperada. Encuentro unos cuantos bugs que hacen referencia a este problema y una solución: desactivar las tecnologías de asistencia (Sistema>Preferencias>Tecnologías de asistencia).

Una vez solucionado esto, me dispongo a actualizar Sublipse. Después de algunos intentos lo consigo, pero usando el fichero site-1.6.5.zip, con la URL de actualización no va.

Hay que tener en cuenta que para que Subclipse encuentre la librería JavaHL de Subversion hay que añadir la siguiente línea en el fichero eclipse.sh:

export LD_LIBRARY_PATH=/usr/lib/jni

Listo, parece que Eclipse ya se lleva bien con Ubuntu 9.10.